Series25 Technical Specifications


Port Usage

With a Software as a Service (SaaS) deployment of Series25®, all data and tools reside on CollegeNET servers, and users access everything via the Internet over secure connections. The diagram below shows standard port numbers used for connections with arrows indicating the direction of initial requests.

Diagram of ports running between a school and Series25Image: Series25 Port Diagram

→ Direction of Initial Request → Port
25Live

Series25 Application Tools Servers

Publisher Server

Custom Reports Server

443

SIS

Series25 WebServices

1521 (Oracle)

1433 (MSS)

Series25 LYNX InterfaceLYNX WebServices443

Series25 WebServices

Single Sign-On

636 (typically)

Web Browsers

Series25 tools may be accessed using any of the following browsers:

  • Mozilla Firefox
  • Google Chrome
  • Microsoft Edge
  • Apple Safari
  • Built-in browsers on iOS and Android

Note: The system supports the latest version of any of the browsers listed above, and up to two major versions back. There may be minor display differences among browsers due to variations of Web standards.

Single Sign-On (optional)

In addition to native authentication within the software itself, Series25 offers the option to implement single sign-on integrations. This includes automatic user provisioning in Series25 upon login.

CollegeNET maintains hundreds of SSO configurations in our SaaS environments and supports multiple authentication protocols:

  • LDAP (including Active Directory)
  • SAML 2.0 (including Shibboleth)

Our Series25 development and support teams have supported SSO for over a decade, and we are a member of the InCommon Federation.

Requirements for supported authentication:

  • In order to implement LDAP authentication, CollegeNET requires an open connection from our servers to your LDAP server. We will also need a bind user (to connect for authentication) and a test user.
  • For Shibboleth and SAML 2.0 compliant authentication protocols, we first require the URL with your IdP’s metadata, or your entityID if your metadata is in InCommon. After providing this piece you tell us what attributes to map, and we set up the server.

For further information, see the Shibboleth pages in the Exclusive Customer Resources section (login required). 

Series25 LYNX Interface

Depending on the SIS used, a lightweight Java service, the LYNX-APP, must be installed at your institution. Our Technical Support representatives can help if you have a different SIS than those listed below.

LYNX for Banner Interface Database Requirements

  • Banner version 8+
  • Both phase 1 and phase 2 of Banner's Database Extension Utility (DBEU) have been implemented
  • Oracle Database 11g r2, 12c, 18c, or 19c

LYNX for Campus Solutions Interface Database Requirements

  • Oracle: Oracle PeopleSoft Campus Solutions 8.9+, Oracle Database 11g r2, 12c, 18c, or 19c
  • MS SQL: MS SQL Server 2012 or later, TLS 1.2+ for MS SQL Server

LYNX for Colleague (MS SQL and Unidata) Database Requirements

  • MS SQL: MS SQL Server 2012 or later, TLS 1.2+ for MS SQL Server
  • Unidata: Colleague Release 18 and Data transactions (2002), Colleague App Listener (DMI updates), Microsoft SQL database 2012+,  Windows Server 2012+, .NET Framework 4.5+, Colleague .NET SDK 1.17 or 1.23

LYNX Universal Interface Database Requirements

  • Oracle:  Oracle Database 11g r2, 12c, 18c, or 19c
  • MS SQL: MS SQL Server 2012 or later, TLS 1.2+ for MS SQL Server

LYNX for Workday Interface Database Requirements

  • A functioning instance of Workday Student

LYNX for Ethos Interface Database Requirements

  • A functioning instance of Ethos

Series25 LYNX LYNX-APP Server Requirements

(not required for Workday or Ethos API integration)

The Series25 LYNX Interface LYNX-APP Service is required for any locally hosted SIS. It is a lightweight Java application that transmits data to and from your Series25 environment hosted by CollegeNET.

  • CPU: 1 GHz minimum
  • RAM: 1 GB minimum
  • Hard disk space: 10 GB

Note:  For information on installing the LYNX-APP server-side service, see the LYNX Interface - Installation Overview

Supported OS Options

  • Windows Server
  • Windows 10
  • Linux

LYNX-APP Service Java Support

  • Java 8-17

Java JDK Note: Due to Oracle’s subscription model for JDK licensing, CollegeNET recommends that LYNX customers use the free OpenJDK to avoid fees from Oracle. OpenJDK does not yet work with the 25Live Interactive Report Designer (JReport).

If You’re Considering a Virtual Environment

The LYNX-APP server-side service can be installed in a virtualized environment. Please be aware, however, that Series25 Customer Support cannot troubleshoot configuration issues specific to virtual servers.

Running Reports

Adobe Reader or another PDF reader must be installed when running 25Live Reports, which use Series25 WebServices.

Some reports are also available to download and view in Excel/spreadsheet format and require a spreadsheet application, such as Microsoft Excel or OpenOffice Calc.