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Creating and Managing Custom Documents

In This Article:
What Can You Do With The Custom Document Feature?

Creating a New Custom Document

Editing Custom Documents

Deleting an Existing Custom Document

Security Note: This Feature Requires Special Security Access

If you need permission to use this feature, contact your 25Live Administrator. In the Series25 Group
Administration tool, they can set Administrative: 4.0 Event Document Creation and Management  to Yes to
allow access to your security group.

Object Security policies are enforced when editing custom documents. See How Security and Policy Settings
Work Together

To create documents, you must have access to the resources used in the document. These may include:

Event Document Creation and Management = Yes
Manage Report Parameters and Schedule Reports = Yes

See note below about scheduling reports.

Override Report Security = Yes 
OR, you may have at least view permissions on the following reports (as they are listed in
Report Security in the Series25 Group Administration tool):

Event Contract

Reservation Shell

Event Organization Shell

Events Table Builder

Reservations By Date Table Builder

Locations Table Builder

Resources Table Builder

Organizations Table Builder

If you don't have the necessary permissions, the "Create Document" button may be disabled or hidden.

What Can You Do With The Custom Document Feature?

http://knowledge25.knowledgeowl.com/#what-can-you-do-with-the-custom-document-feature-
http://knowledge25.knowledgeowl.com/#creating-a-new-custom-document
http://knowledge25.knowledgeowl.com/#editing-custom-documents
http://knowledge25.knowledgeowl.com/#deleting-an-existing-custom-document
http://knowledge25.knowledgeowl.com/help/permissions-in-series25-group-administration
http://knowledge25.knowledgeowl.com/help/how-security-and-policy-settings-work-together
http://knowledge25.knowledgeowl.com/help/configuring-object-security
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Users with appropriate permissions (See the Series25 Group Administration tool help) can easily create and edit custom
documents (such as event contracts) by adding content for:

Header (top of the document)
Body (middle/main section of the document)
Footer (bottom of the document)

This feature allows the creation of content more quickly and easily than creating a full custom report (which can now
be reserved for creating more complex content). Custom content can include rich text, images, links, tables, and many
variables for including event information.

After creation, custom documents can be printed with events using the More Actions section in the Event Details  view
as well as included in emails.

Creating a New Custom Document

1. Go to the Document Management View in System Settings
The System Settings section is accessible from the More menu in the top navigation bar.

Image: Example of a custom event contract.

Image: The More menu in the top navigation bar has a link to the System Settings view.

http://knowledge25.knowledgeowl.com/help/permissions-in-series25-group-administration
http://knowledge25.knowledgeowl.com/help/document-management-variable-reference-and-examples
http://knowledge25.knowledgeowl.com/help/viewing-event-details
http://knowledge25.knowledgeowl.com/help/using-the-top-navigation-bar
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Use the menu link to go to the System Settings view, then continue to the Document Management section.

2. Choose Create Document and Enter a Name

In the Documents section, tap the Create Document button. If you don't have the necessary permissions, this
button may be disabled or hidden.

At the top of the form, enter a Document Name. This is an internal (not public) name used for organization.

Image: The System Settings link in the
More menu.

Image: The Document Management section is the System Settings.

Image: Use the Create Document button to open the configuration form.
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3. Choose the Scope of the Document
Use the Choose the scope of the document dropdown menu to choose between:

Event Based - the custom document will be scoped to the entire event

Reservation Based- this option allows you to choose one reservation that the document will be scoped to and
offers special reservation-based template variables to include in the content

Example Use: A confirmation or catering document that only displays resources and instructions for one
occurrence. 

Organization Based - this custom document will be scoped to the event's organization
Example Use: A contract copy for each organization on an event that only displays the billed items and
totals that belong to the receiving organization.

Invoice (Payment) - this custom document allows you to create payment invoice documents for your events 

These Excel documents each have a matching standard report in 25Live Reports. When one of the following scopes is
selected, you will be presented with a Table Builder interface, which allows you to choose which columns will be output
in the report. Each of these report scopes will generate an Excel-formatted output file with a .xml file extension.

Event Listing - Excel - This report lists summary information for all events in an event search.
Report Parameter(s): Start Date, End Date, Event Search

See the matching standard report for a listing of some of the options available for table columns.

Reservations by Date - Excel - This report shows event information for a specified date range.
Report Parameter(s): Start Date, End Date, Event Search, Location Search (optional)

See the matching standard report for a listing of some of the options available for table columns.

Location Listing - Excel - This report lists specified locations.
Report Parameter(s): Location Search

Resource Listing - Excel - This report lists specified resources.
Report Parameter(s): Resource Search

Image: Enter a Document Name, Document Scope, and Output
Filename.

http://knowledge25.knowledgeowl.com/help/25live-standard-reports-reference-help
http://knowledge25.knowledgeowl.com/help/document-management-variable-reference-and-examples#table-builder
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Organization Listing - Excel - This report lists specified organizations.
Report Parameter(s): Organization Search

Invoice Details - Excel (Payment) - This report lists pricing details related to payment activity.
Report Parameter(s): Start Date, End Date, Event Search

4. Update the Output Filename
This will be the name of the document when users download this report.

5. Enter a Description
Add a summary of the document in the Description field. This content is displayed in your list of documents to help
you differentiate documents.

6. Complete the Header, Body, and Footer Sections

The Header field controls what will show at the top of your custom document.

Use the Body field to add content to the middle of your document.

The Footer field will be displayed at the bottom of the document.

All three content fields feature many formatting options that are similar to what you find in other areas of 25Live as
well as in many common internet applications for bold, italic, and changing font type and font size.

Adding Links

Image: Content fields offer many formatting and other content options.
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The link icon ( ) provides the ability to create links on text or images. Simply highlight the text or image, enter the
URL (address), title for the link (important for accessibility), and choose whether you want the link to open in the
current window or a new window/tab.

Tip: Viewing Source Code

If you are very technical, you can use the Tools > Source Code option to edit the source code in any content
field.

Adding Images 

Use the Insert menu at the top of any of the fields, and choose the Image option to enter:

The URL Source for the image (Once an image is uploaded to 25Live through System Settings > Master Definitions
> Images, the URL can be retrieved using the "Copy Link" button)

Note: You may also use a URL to an image hosted on your institution's website(s).

The Alternative description is important for use of accessible screen readers

The Width and Height of the image (if different than the auto-completed values)

Image: After completing the options, the link will appear underlined in blue by default.

Image: After adding an image, it will appear in the content field.

http://knowledge25.knowledgeowl.com/help/adding-and-managing-images
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The image will display within the field if the URL is correct. Click or tap on the image again to edit its options.

Using Tables

At the top of the field, use the Insert dropdown menu and the Table option. You will then need to complete:

The number of columns (Cols) and Rows needed in your table

Width and Height of your table are expressed as a percentage or pixels (100% is the easiest recommendation)

The number of pixels for a Border width (0 for none)

If a Caption should display (useful for screen readers)

And the Alignment to display the table in (useful if less than 100% width)

If you use the link to the Advanced section, for additional border and color options.

Using Template Variables

Template variables are encoded values that will pull data dynamically into your custom documents, such as an event
requestor's email, an event name, and custom variables.

View List of Template Variable Examples

You can expand the Template Variables section below the Header, Body, and Footer sections to easily choose and
copy the exact syntax needed for variables. 

If you choose to create a Reservation Based document, special template variables are available to you, which will
appear in the Template Variables section.

Image: The table options include the size and alignment of the table.

Image: Use the down arrow on the right side of the section header to reveal Template Variable options.

http://knowledge25.knowledgeowl.com/help/document-management-variable-reference-and-examples


CollegeNET Series25 Help and Customer Resources

Copyright CollegeNET, Page 8
This content is intended only for licenced CollegeNET Series25 customers. Unauthorized use is prohibited.

6. Preview Your Document
You're encouraged to preview your document before finishing. 25Live allows you to preview your document using an
internal Event Reference, which is in the format of:

 Four-digit year Dash Six uppercase letters

2025 - AAZHZA

This reference ID will pull information from the event to populate any template variables used in the content.

If you choose to scope the custom document as Reservation Based, after entering the event reference ID, use
the Load Reservations button to Select an occurrence to preview.

Note: Preview Data is Limited to 25 Records

Data you see in previews with long variable output is limited to 25 records for faster performance.

Image: Variables can be generated by interacting with the elements in the Template Variables section.

Image: Reservation Based documents allow you to choose reservations to preview.
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7. Save Your Document
Use the Save button to complete creating your custom document.

You are now ready to utilize your custom document.

For example, you can schedule non-object specific custom documents that are Excel-based, such as on a daily
or weekly basis. Object-specific reports cannot be scheduled.

Tip: Add Object Security Rights

Document Management reports use Object Security. Use Group Administration > Configure Report Security
to update which groups can view, edit, delete, and copy this report.

Editing Custom Documents

1. Go to the Document Management View in System Settings
The System Settings section is accessible from the More menu in the top navigation bar.

Use the menu link to go to the System Settings view, then continue to the Document Management section.

Image: The More menu in the top navigation bar has a link to the System Settings view.

Image: The System Settings link in the
More menu.

Image: The Document Management section is the System Settings.

http://knowledge25.knowledgeowl.com/help/utilizing-custom-contract-documents
http://knowledge25.knowledgeowl.com/help/configuring-object-security
http://knowledge25.knowledgeowl.com/help/using-the-top-navigation-bar
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2. Tap View

In the left-side, blue menu bar, choose Documents.

Tap View to edit the document.

3. Make Your Changes
Please refer to the above section Creating a New Document  for descriptions of buttons and fields.

Changing the Document Scope Isn't Recommended

Be careful changing the document scope. If you used any special Reservation Based template variables in
your content, and then change to an Event Based scope, your content may not appear as expected.

4. Preview Your Document
You can preview your document using an internal Event Reference, which is in the format of:

Four-digit year Dash Six uppercase letters

2025 - AAZHZA

This reference ID will pull information from the event to populate any template variables used in the content.

5. Save Your Document
Use the Save button to save changes, or Cancel to discard all changes.

Deleting an Existing Custom Document

1. Go to the Document Management View in System Settings
The System Settings section is accessible from the More menu in the top navigation bar.

Image: The Edit Document link is in the blue side menu.

http://knowledge25.knowledgeowl.com/help/using-the-top-navigation-bar
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Use the menu link to go to the System Settings view, then continue to the Document Management section.

2. Tap Delete

In the Documents tab, select the Delete button next to the document you want to permanently remove from 25Live.

3. Confirm

Image: The More menu in the top navigation bar has a link to the System Settings view.

Image: The System Settings link in the
More menu.

Image: The Document Management section is the System Settings.

Image: The Edit Document link is in the blue side menu.
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Confirm to save this change. This action cannot be undone.

Next, see Utilizing Custom Documents .

http://knowledge25.knowledgeowl.com/help/utilizing-custom-contract-documents

